$re = '/^(.*?),\s*/m';
$str = 'software.cisco.com , Added by IT, ZZ 6584';
$subst = "$1\n#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;