re = /^(.*?),\s*/m
str = 'software.cisco.com , Added by IT, ZZ 6584'
subst = '$1\\n#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result