use strict;
my $str = 'software.cisco.com , Added by IT, ZZ 6584';
my $regex = qr/^(.*?),\s*/mp;
my $subst = '$1\\n#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";