const regex = /^(.*?),\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?),\\s*', 'gm')
const str = `software.cisco.com , Added by IT, ZZ 6584`;
const subst = `$1\n#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);