package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?),\s*`)
var str = `software.cisco.com , Added by IT, ZZ 6584`
var substitution = "$1\n#"
fmt.Println(re.ReplaceAllString(str, substitution))
}