// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?),\s*").unwrap();
let string = "software.cisco.com , Added by IT, ZZ 6584";
let substitution = "$1\\n#";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}