using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=[\\a-zA-Z\{\}\[\]\-$%!=]{4,}";
string input = @"=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}==";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}