import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=[\\\\a-zA-Z\\{\\}\\[\\]\\-$%!=]{4,}";
final String string = "=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}==";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}