const regex = /=[\\a-zA-Z\{\}\[\]\-$%!=]{4,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=[\\\\a-zA-Z\\{\\}\\[\\]\\-$%!=]{4,}', '')
const str = `=2isjTsONZb!UrkVmsostBb}-KRL%R\$E\\\\fQ{m\$0lTVuwN!qFFkh0f\$v]]wIir]vIY\$SLUXJyyi-GFlJhohxgfH}==`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}