package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`=[\\a-zA-Z\{\}\[\]\-$%!=]{4,}`)
var str = `=2isjTsONZb!UrkVmsostBb}-KRL%R$E\\fQ{m$0lTVuwN!qFFkh0f$v]]wIir]vIY$SLUXJyyi-GFlJhohxgfH}==`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}