package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S)\b((?:S\d+)?EP?\d+\b)`)
var str = `克隆人战争S01E02 2008.720p-CMCT`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}