// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\S)\b((?:S\d+)?EP?\d+\b)").unwrap();
let string = "克隆人战争S01E02 2008.720p-CMCT";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}