use strict;
my $str = '克隆人战争S01E02 2008.720p-CMCT';
my $regex = qr/(\S)\b((?:S\d+)?EP?\d+\b)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";