$re = '/(\S)\b((?:S\d+)?EP?\d+\b)/m';
$str = '克隆人战争S01E02 2008.720p-CMCT';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;