# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(([\w-]+)[.]((\w{2,}$)|(?R)))/m: \1 host: \2 domain: \3/gm;t' <<< "a.b.c.de
a.b.co
a.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com"