use strict;
my $str = 'a.b.c.de
a.b.co
a.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com';
my $regex = qr/(([\w-]+)[.]((\w{2,}$)|(?R)))/mp;
my $subst = 'm: \\1 host: \\2 domain: \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";