import Foundation
let pattern = #"(([\w-]+)[.]((\w{2,}$)|(?R)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a.b.c.de
a.b.co
a.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"m: \1 host: \2 domain: \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)