re = /(([\w-]+)[.]((\w{2,}$)|(?R)))/m
str = 'a.b.c.de
a.b.co
a.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com'
subst = 'm: \\1 host: \\2 domain: \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result