import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([\\w-]+)[.]((\\w{2,}$)|(?R)))";
final String string = "a.b.c.de\n"
+ "a.b.co\n"
+ "a.com\n"
+ "b-app05-06.boldchat.com\n"
+ "ns126a.ba1.enops.net\n"
+ "NHQSDFEXCHUB01.nam.coair.com\n"
+ "ncsmcexchub01.nam.coair.com";
final String subst = "m: \\1 host: \\2 domain: \\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}