package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([\w-]+)[.]((\w{2,}$)|(?R)))`)
var str = `a.b.c.de
a.b.co
a.com
b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com`
var substitution = "m: \1 host: \2 domain: \3"
fmt.Println(re.ReplaceAllString(str, substitution))
}