#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(([\w-]+)[.]((\w{2,}$)|(?R)))"
Local $sString = "a.b.c.de" & @CRLF & _
"a.b.co" & @CRLF & _
"a.com" & @CRLF & _
"b-app05-06.boldchat.com" & @CRLF & _
"ns126a.ba1.enops.net" & @CRLF & _
"NHQSDFEXCHUB01.nam.coair.com" & @CRLF & _
"ncsmcexchub01.nam.coair.com"
Local $sSubst = "m: \1 host: \2 domain: \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)