#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)"
Local $sString = "Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")