re = /(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)/
str = 'Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end