import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<name>[a-zA-Z\\s]+)\\(Amount\\:\\s?(?<amount>[0-9\\s\\.a-zA-Z]+)\\,\\s?Select\\sOption\\:\\s?(?P<select_option>.+)\\,\\s?(?P=name)\\s?\\(CRM\\)\\:\\s?([0-9]+)\\)";
final String string = "Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}