const regex = /(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<name>[a-zA-Z\\s]+)\\(Amount\\:\\s?(?<amount>[0-9\\s\\.a-zA-Z]+)\\,\\s?Select\\sOption\\:\\s?(?P<select_option>.+)\\,\\s?(?P=name)\\s?\\(CRM\\)\\:\\s?([0-9]+)\\)', 'g')
const str = `Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}