// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)").unwrap();
let string = "Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}