using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)";
string input = @"Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}