package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)`)
var str = `Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}