import Foundation
let pattern = #"(?P<name>[a-zA-Z\s]+)\(Amount\:\s?(?<amount>[0-9\s\.a-zA-Z]+)\,\s?Select\sOption\:\s?(?P<select_option>.+)\,\s?(?P=name)\s?\(CRM\)\:\s?([0-9]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Product One (Amount: 199.99 USD, Select Option: Option One, Product One (CRM): 1)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)