#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?-i)AAA\/[A-Z]{0,8}\/AAA"
Local $sString = "AAA/BB/AAA" & @CRLF & _
"AAA//AAA" & @CRLF & _
"AAA/AABBCCDD/AAA" & @CRLF & _
"" & @CRLF & _
"Don't match" & @CRLF & _
"AAA/AABBCCDDE/AAA" & @CRLF & _
"AAA/BBCCDDEEFF/AAA" & @CRLF & _
"AAA/bb/AAA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")