re = /(?-i)AAA\/[A-Z]{0,8}\/AAA/i
str = 'AAA/BB/AAA
AAA//AAA
AAA/AABBCCDD/AAA
Don\'t match
AAA/AABBCCDDE/AAA
AAA/BBCCDDEEFF/AAA
AAA/bb/AAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end