import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?-i)AAA\\/[A-Z]{0,8}\\/AAA";
final String string = "AAA/BB/AAA\n"
+ "AAA//AAA\n"
+ "AAA/AABBCCDD/AAA\n\n"
+ "Don't match\n"
+ "AAA/AABBCCDDE/AAA\n"
+ "AAA/BBCCDDEEFF/AAA\n"
+ "AAA/bb/AAA";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}