package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?-i)AAA\/[A-Z]{0,8}\/AAA`)
var str = `AAA/BB/AAA
AAA//AAA
AAA/AABBCCDD/AAA
Don't match
AAA/AABBCCDDE/AAA
AAA/BBCCDDEEFF/AAA
AAA/bb/AAA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}