// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?-i)AAA\/[A-Z]{0,8}\/AAA").unwrap();
let string = "AAA/BB/AAA
AAA//AAA
AAA/AABBCCDD/AAA
Don't match
AAA/AABBCCDDE/AAA
AAA/BBCCDDEEFF/AAA
AAA/bb/AAA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}