const regex = /(?-i)AAA\/[A-Z]{0,8}\/AAA/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-i)AAA\\\/[A-Z]{0,8}\\\/AAA', 'gi')
const str = `AAA/BB/AAA
AAA//AAA
AAA/AABBCCDD/AAA
Don't match
AAA/AABBCCDDE/AAA
AAA/BBCCDDEEFF/AAA
AAA/bb/AAA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}