import Foundation
let pattern = #"(?-i)AAA\/[A-Z]{0,8}\/AAA"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
AAA/BB/AAA
AAA//AAA
AAA/AABBCCDD/AAA
Don't match
AAA/AABBCCDDE/AAA
AAA/BBCCDDEEFF/AAA
AAA/bb/AAA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)