$re = '/(?-i)AAA\/[A-Z]{0,8}\/AAA/i';
$str = 'AAA/BB/AAA
AAA//AAA
AAA/AABBCCDD/AAA
Don\'t match
AAA/AABBCCDDE/AAA
AAA/BBCCDDEEFF/AAA
AAA/bb/AAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);