using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*((?:(?<item>[^""'\s,]+)|(?<quote>[""'])(?<item>.*?)\<quote>)(?:(?:\s*,?\s*)|$))+$";
string input = @" /tmp/foo&bar / baz,quux 'etc., etc.' ""all well 'n good"", '3"" of snow' ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}