import Foundation
let pattern = #"^\s*((?:(?<item>[^""'\s,]+)|(?<quote>[""'])(?<item>.*?)\<quote>)(?:(?:\s*,?\s*)|$))+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #" /tmp/foo&bar / baz,quux 'etc., etc.' "all well 'n good", '3" of snow' "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)