$re = '/^\s*((?:(?<item>[^""\'\s,]+)|(?<quote>[""\'])(?<item>.*?)\<quote>)(?:(?:\s*,?\s*)|$))+$/i';
$str = ' /tmp/foo&bar / baz,quux \'etc., etc.\' "all well \'n good", \'3" of snow\' ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);