// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)^\s*((?:(?<item>[^""'\s,]+)|(?<quote>[""'])(?<item>.*?)\<quote>)(?:(?:\s*,?\s*)|$))+$"#).unwrap();
let string = " /tmp/foo&bar / baz,quux 'etc., etc.' \"all well 'n good\", '3\" of snow' ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}