import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*((?:(?<item>[^\"\"'\\s,]+)|(?<quote>[\"\"'])(?<item>.*?)\\<quote>)(?:(?:\\s*,?\\s*)|$))+$";
final String string = " /tmp/foo&bar / baz,quux 'etc., etc.' \"all well 'n good\", '3\" of snow' ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}