const regex = new RegExp('^\\s*((?:(?<item>[^""\\'\\s,]+)|(?<quote>[""\\'])(?<item>.*?)\\<quote>)(?:(?:\\s*,?\\s*)|$))+$', 'gi')
const str = ` /tmp/foo&bar / baz,quux 'etc., etc.' "all well 'n good", '3" of snow' `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}