re = /^\s*((?:(?<item>[^""'\s,]+)|(?<quote>[""'])(?<item>.*?)\<quote>)(?:(?:\s*,?\s*)|$))+$/i
str = ' /tmp/foo&bar / baz,quux \'etc., etc.\' "all well \'n good", \'3" of snow\' '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end