package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\s*((?:(?<item>[^""'\s,]+)|(?<quote>[""'])(?<item>.*?)\<quote>)(?:(?:\s*,?\s*)|$))+$`)
var str = ` /tmp/foo&bar / baz,quux 'etc., etc.' "all well 'n good", '3" of snow' `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}