#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$"
Local $sString = "1500" & @CRLF & _
"26489" & @CRLF & _
"212" & @CRLF & _
"15849" & @CRLF & _
"5000" & @CRLF & _
"5001" & @CRLF & _
"4584" & @CRLF & _
"2402" & @CRLF & _
"5191981" & @CRLF & _
"4618916" & @CRLF & _
"6540" & @CRLF & _
"4500" & @CRLF & _
"45000" & @CRLF & _
"9999999" & @CRLF & _
"4001" & @CRLF & _
"4000" & @CRLF & _
"3999" & @CRLF & _
"5999" & @CRLF & _
"6000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")