import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-3]|[6-9])[0-9]*|[54]\\d{4,}$";
final String string = "1500\n"
+ "26489\n"
+ "212\n"
+ "15849\n"
+ "5000\n"
+ "5001\n"
+ "4584\n"
+ "2402\n"
+ "5191981\n"
+ "4618916\n"
+ "6540\n"
+ "4500\n"
+ "45000\n"
+ "9999999\n"
+ "4001\n"
+ "4000\n"
+ "3999\n"
+ "5999\n"
+ "6000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}