const regex = /^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-3]|[6-9])[0-9]*|[54]\\d{4,}$', 'gm')
const str = `1500
26489
212
15849
5000
5001
4584
2402
5191981
4618916
6540
4500
45000
9999999
4001
4000
3999
5999
6000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}