package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$`)
var str = `1500
26489
212
15849
5000
5001
4584
2402
5191981
4618916
6540
4500
45000
9999999
4001
4000
3999
5999
6000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}