# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$"
test_str = ("1500\n"
"26489\n"
"212\n"
"15849\n"
"5000\n"
"5001\n"
"4584\n"
"2402\n"
"5191981\n"
"4618916\n"
"6540\n"
"4500\n"
"45000\n"
"9999999\n"
"4001\n"
"4000\n"
"3999\n"
"5999\n"
"6000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.